在Ubuntu IP的SSH-Mac终端上无法找到libtool-ltdl-devel软件包。

0

【以下的问题经过翻译处理】 亲爱的社区成员,

我已经成功连接了SSH客户端到我的Mac终端。

现在我遇到了另一个问题,我在第4步中跟随了https://docs.aws.amazon.com/managed-blockchain/latest/hyperledger-fabric-dev/get-started-create-client.html

我尝试安装-->sudo yum install jq telnet emacs docker libtool libtool-ltdl-devel git -y(注意:对于Ubuntu,“yum”命令用作apt或apt-get)

但我遇到了以下错误:

sudo apt install jq telnet emacs docker libtool libtool-ltdl-devel git -y 已读取软件包列表...完成 已经构建依赖关系树...完成 已经读取状态信息...完成 无法定位软件包libtool-ltdl-devel

我已经尝试了这个链接的所有4种方法--> https://itslinuxfoss.com/unable-locate-package-error-ubuntu/#2,但是错误“E: Unable to locate package libtool-ltdl-devel”仍然存在。我尝试搜索相关的问题,但没有找到。

我正在使用ubuntu-jammy-22.04-arm64-server-20230303,以上软件包拼写是否正确?还是因为我使用的Ubuntu版本不支持它?

请指导,谢谢。

profile picture
专家
已提问 5 个月前6 查看次数
1 回答
0

【以下的回答经过翻译处理】 在Ubuntu软件仓库中,libtool-ltdl-devel的包名似乎不同。你应该安装libltdl-dev。请执行以下命令进行安装:sudo apt update && sudo apt install jq telnet emacs docker libtool libltdl-dev git -y。

profile picture
专家
已回答 5 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则