AWS SAM CLI错误:错误:PythonPipBuilder:ResolveDependencies - {pyyaml == 6.0(wheel)}

0

【以下的问题经过翻译处理】 我一直遇到标题中提到的相同错误,尽管我已经安装了wheel。我已尝试使用sam build --use-container(文件夹中有一个template.yaml文件),但它导致了另一个错误(Error: Docker is unreachable. Docker needs to be running to build inside a container)。

profile picture
专家
已提问 5 个月前47 查看次数
1 回答
0

【以下的回答经过翻译处理】 您的机器上是否已安装并运行Docker守护进程?如果您想要使用sam build --use-container命令,请确保已安装并运行了Docker来测试您的应用程序并构建部署包。请参阅https://docs.aws.amazon.com/serverless-application-model/latest/developerguide/serverless-sam-cli-install-windows.html的第3步“安装Docker”一节,该节提到:“仅当您需要在本地测试应用程序并使用--use-container选项构建部署包时,Docker才是一个先决条件。如果您一开始不打算使用这些功能,则可以跳过此部分或稍后安装Docker。”因此,如果您使用--use-container选项,则需要在机器上运行Docker。

profile picture
专家
已回答 5 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则