AWS App Runner Stuck

0

Hi

I've tried starting up an app runner service using a custom Docker container, and it seems to be stuck. My log messages are as follows:

08-21-2021 10:51 PM [AppRunner] Successfully created pipeline for automatic deployments.
08-21-2021 10:51 PM [AppRunner] Service status is set to OPERATION_IN_PROGRESS.
08-21-2021 10:51 PM [AppRunner] Service creation started.

Unfortunately, these were created 40 minutes ago at the time of writing and I can't see any update from here. I tried using the aws console to delete the running service, but I get the following error message:

An error occurred (InvalidStateException) when calling the DeleteService operation: Service cannot be deleted in the current state: OPERATION_IN_PROGRESS.

I can't do anything, e.g. update env variables, use the console to delete etc. Is there anything else I can do as it looks stuck. Has anyone else had this issue before?

Simmy

已提问 3 年前989 查看次数
1 回答
0

Ah it finally failed out enabling me to delete it just after I posted. I think that role provided doesn't have access to the container registry, so that's a learning point for me.

已回答 3 年前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则