Amazon Linux 2023 中的 libvips

0

【以下的问题经过翻译处理】 我想在AL2023中安装libvips

然而,libvips似乎不在Amazon Linux 2023软件包列表中,所以sudo dnf install libvips不能解决问题。

我已经尝试了从源代码构建libvips,但是虽然AL2023具有像mesonninja-build这样的依赖项软件包,但它缺少必须的依赖项如libgliblibexpat

是否有编译libvips以适用于AL2023的方法,或者有没有地方可以请求将其添加到软件包列表中?

profile picture
专家
已提问 3 个月前11 查看次数
1 回答
0

【以下的回答经过翻译处理】 不幸的是,amazon-linux-extras包已从AL 2023中删除[1]。因此,您将无法安装需要该包的任何软件包,目前AWS也没有未来支持EPEL在AL2023上的计划。请注意,AWS建议客户不要尝试在AL2023上启用EPEL,因为它不受支持且不兼容,可能会导致EPEL或AL2023无法正常工作。如果您认为Amazon Linux 2023不是您所需的特定操作系统,则建议您改用Amazon Linux 2(AL2)AMI。我已经尝试使用以下参考命令设置此软件包,可以确认它可以正常工作。[+] https://tufora.com/tutorials/linux/general/install-vips-vips-tools-and-vips-devel-libvips-on-centos-7我还与AWS技术支持团队确认了这一点。

profile picture
专家
已回答 3 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则