无法使用最新的SolutionStack进行NodeJS部署。

0

【以下的问题经过翻译处理】 用解决方案栈名称:"64位Amazon Linux 2018.03 v4.8.0运行Node.js",但我收到一个错误信息:"没有找到名为'64位Amazon Linux 2018.03 v4.8.0运行Node.js'的解决方案栈。(服务:AWSElasticBeanstalk;状态代码:400;错误代码:InvalidParameterValue;)"。

然而,我正在使用栈的最新版本...几周前它在之前的版本中可以工作。你能帮我吗?我在eu-west-1地区。

profile picture
专家
已提问 6 个月前15 查看次数
1 回答
0

【以下的回答经过翻译处理】 您的账户在eu-west-1中没有“64位Amazon Linux 2018.03 v4.8.0运行Node.js”的解决方案堆栈。要获取可用的解决方案堆栈集合,您可以在Bash shell中执行以下AWS CLI命令:

aws elasticbeanstalk list-available-solution-stacks --region eu-west-1 | grep "SolutionStackName.*Node.js"

例如,当我运行上述命令时,我看到以下内容可用,也有其他:

"SolutionStackName": "64位Amazon Linux 2018.03 v4.8.2运行Node.js",

profile picture
专家
已回答 6 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则