将RDS Aurora Postgres从13.4升级至14.4。

0

【以下的问题经过翻译处理】 你好,

我有一个已经运行良好的13.4数据库应用。我应该如何在14.4上测试它?AWS有什么建议?我是否需要创建另一个14.4的集群来进行测试?

profile picture
专家
已提问 6 个月前47 查看次数
1 回答
0

【以下的回答经过翻译处理】 你好,

对于RDS Aurora Postgres,最简单的方法是使用从快照还原集群的方法。

在这种方法中,你可以创建一个集群快照,并在快照处于可用状态后,进入RDS控制台中的快照部分,并选择你刚刚创建的快照。然后在操作列表中,选择还原快照。在那里,你可以看到可用的引擎版本,你可以选择升级集群。请注意,你只能更新列出的引擎版本。一旦选择,将创建具有新引擎版本的新集群。

还有不同的方法,你可以参考以下链接了解更多信息和不同的方法:

https://aws.amazon.com/blogs/database/part-1-upgrade-your-amazon-rds-for-postgresql-database-comparing-upgrade-approaches/

https://aws.amazon.com/blogs/database/part-2-upgrade-your-amazon-rds-for-postgresql-database-using-the-pglogical-extension/

https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/aurora-restore-snapshot.html

profile picture
专家
已回答 6 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则