在AWS EC2 F1上构建和安装XRT报错

0

【以下的问题经过翻译处理】 我正在升级F1实例上的XRT,但是在升级后我找不到FPGA设备了。虽然我可以在lspci中找到设备,但我不能再加载AFI(hello world afi)。

$ lspci
...
00:1b.0 Memory controller: Amazon.com, Inc. Device f000
00:1c.0 Memory controller: Amazon.com, Inc. Device 1041
00:1d.0 Memory controller: Amazon.com, Inc. Device f000
00:1e.0 Memory controller: Amazon.com, Inc. Device 1041
$ xbutil scan
INFO: Found total 0 card(s), 0 are usable
System Configuration  
OS name:	Linux  
Release:	5.4.0-1025-aws  
Version:	#25~18.04.1-Ubuntu SMP Fri Sep 11 12:03:04 UTC 2020  
Machine:	x86_64  
Model:		HVM domU  
CPU cores:	16  
Memory:		245642 MB  
Glibc:		2.27  
Distribution:	Ubuntu 18.04.4 LTS  
Now:		Tue Sep 29 04:46:36 2020 GMT  
XRT Information
Version: 2.8.0
Git Hash: 5d0ccb4f90d39202644f07de9648743d986a7e68
Git Branch: master
Build Date: 2020-09-29 04:26:24
XOCL: unknown
XCLMGMT: unknown

问题看起来像是没有安装XOCL。 所以我重新安装了所有内容,检查了每个步骤,发现当我这样做: sudo apt install --reinstall ./xrt_202020.2.8.0_18.04-amd64-xrt.deb

错误如下: Unregistering old XRT Linux kernel module sources 2.8.0 from dkms on Ubuntu/Debian


Deleting module version: 2.8.0 completely from the DKMS tree. Done. Cleanup is skipped for package upgrade/downgrade/re-install on Ubuntu/Debian Unpacking xrt (2.8.0) over (2.8.0) ... Setting up xrt (2.8.0) ... Unloading old XRT Linux kernel modules rmmod: ERROR: Module xocl is not currently loaded rmmod: ERROR: Module xclmgmt is not currently loaded Invoking DKMS common.postinst for xrt Loading new xrt-2.8.0 DKMS files... Building for 5.4.0-1025-aws Building initial module for 5.4.0-1025-aws ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/xrt.0.crash' Error! Build of xclmgmt.ko failed for: 5.4.0-1025-aws (x86_64) Consult the make.log in the build directory /var/lib/dkms/xrt/2.8.0/build/ for more information. Finished DKMS common.postinst Loading new XRT Linux kernel modules modprobe: FATAL: Module xclmgmt not found in directory /lib/modules/5.4.0-1025-aws modprobe: FATAL: Module xocl not found in directory /lib/modules/5.4.0-1025-aws

DKMS failed to install XRT drivers. Please check if kernel development headers are installed for OS variant used. Check build logs in /var/lib/dkms/xrt/2.8.0


aws-fpga版本:1.4.15 xrt版本:xrt 2.6.0 和 2.8.0

profile picture
专家
已提问 5 个月前25 查看次数
1 回答
0

【以下的回答经过翻译处理】 看起来Ubuntu AWS优化的内核和模块额外文件夹中没有需要此XRT的fpga-mgr模块。

你可以尝试使用不同的内核吗?建议升级内核并重新构建和安装XRT。

sudo apt update
sudo apt install linux-virtual
sudo apt install linux-modules-extra-$(uname -r)
sudo apt purge linux*aws
sudo reboot

这应该能坚决您的问题。

profile picture
专家
已回答 5 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则