Install RabbitMQ Plugin on AmazonMQ

1

Hi, I would like to install "rabbitmq_delayed_message_exchange" plugin to my AmazonMQ, how could I do that?

Thanks.

已提问 2 年前634 查看次数
3 回答
1

We plan to support this plugin in the future (2023 is currently expected timeframe).

AWS
已回答 2 年前
  • Thanks for your information

  • @Trevor_D: Any update on plugin availability? Can we expect it in early 2024 or is going to be postponed?

1

Hi there,

Thank you for your question. Amazon MQ for RabbitMQ doesn't support installing your own plugins for the managed broker. Currently, Amazon MQ for RabbitMQ supports shovel, federation, and consistent hash exchange plugins. For more information, see Amazon MQ for RabbitMQ plugins documentation in the Amazon MQ Developer Guide.

profile pictureAWS
已回答 2 年前
  • Thanks for your reply, do we have another way to install this plugin for Amazon MQ? Is it possible if we would host the RabbitMQ on an EC2 machine then install this plugin? Thanks.

0

Amazon MQ does not support plugins, from the FAQ. Until this is supported, you can install RabbitMQ into an EC2 instance and run RabbitMQ that way until AmazonMQ has the feature set you require and you can migrate at that point.

profile pictureAWS
专家
已回答 1 年前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则