如何升级Greengrass核心?

0

【以下的问题经过翻译处理】 使用Greengrass v2,在云端部署了核心(Nucleus)、Cli、LocalDebugConsole、LogManager和SageMakerEdgeManager等组件。我的开发工作使用本地部署。

如果不彻底清除设备并重新开始,我无法升级Nucleus。我的尝试的升级流程如下:

· 更新本地配方文件中的版本要求,以考虑新的Nucleus版本(在这种情况下为=2.8.1) · 更新云端部署中的Nucleus版本为2.8.1 · 部署!

在任何一种部署(云端或本地)时,我都会出现以下错误:没有可用的版本与=2.8.1和=2.8.1相匹配。这将导致我的设备和部署都处于瘫痪状态,直到我抹掉重来。

有没有人能给我一个逐步过程,告诉我如何升级Nucleus和其他AWS提供的组件?

profile picture
专家
已提问 3 个月前0 查看次数
1 回答
0

【以下的回答经过翻译处理】 对于其他遇到同样问题的人:我通过运行本地部署解决了这个问题,删除了所有本地(开发)组件,运行了Nucleus的云部署,然后重新部署了所有我的开发组件。依赖解析器似乎存在一个错误,无法调整来自云端和本地依赖项的需求。

profile picture
专家
已回答 3 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则