When will you release the new Greengrass Snap providing SDK v1.9.x

0

Hi

The Greengrass Snap currently provides Greengrass 1.8

However 1.8 only works with nodejs 6.10 lambdas. This version of nodejs is about to be deprecated on AWS infrastructure by the end of the month.

It becomes urgent to release the new snap version shipping greengrass 1.9 otherwise it will be impossible to deploy new lambdas to existing greengrass gateways.

Can you communicate on the estimated time of release of the new snap ?

Best regards,

--
Jean-Philippe

Edited by: Jips71 on May 19, 2019 10:25 AM

Jips71
已提问 5 年前274 查看次数
9 回答
0
已接受的回答

Hi Jips71,

We are aware of the issue. Unfortunately we can't provide an estimate for when the Snap package will be updated. I'll update this post with more info as it becomes available.

Thanks,
KR-AWS

AWS
KR-AWS
已回答 5 年前
0

FYI I posted this issue on snapcraft.io for cross referencing : https://forum.snapcraft.io/t/nodejs-runtime-issues-with-the-greengrass-support-interface-and-the-aws-iot-greengrass-snap/11424/4

I’m willing to help but couldn’t identify another place like a Github repo where I would, for example, post a pull-request to update the snap.

Please answer and point me to the right place/direction to contribute if not here :-)

Jips71
已回答 5 年前
0

thanks KR

I hope this will be done soon.

Regards

Jips71
已回答 5 年前
0

Do you have any news on that topic ?

When will the new version of the greengrass snap will be updated ? Right now we are stuck with the non working stack ubuntu core _ aws greengrass _NodeJS ; which is very promising otherwise. My team feels like moving away to another approach and we are craving for any news about a fix to this.

Jips71
已回答 5 年前
0

Hi Jean-Philippe,

Unfortunately I can not communicate an exact date at this time, but can assure you that we're actively working on it.

In the meantime, your team may be able to use the Greengrass docker container with the Docker snap to avoid the need for manual install. Would that be a viable option?

Thanks,
-joe

AWS
已回答 5 年前
0

OK. Thank you very much. A few weeks had passed since the last answer that's why I upped the thread.

Since we have no ETA, and the absence of nodejs lambdas in greengrass is a significant issue to us (because the snap means stability, sandboxing of technical issues "in the wild", and cost effectiveness in production), we inferred that it would be fixed quickly and were waiting "actively" while focusing on other sides of our project. We will now investigate the docker approach that you kindly suggested.

However, since there is no other place to track this topic, I'll ask again in a few weeks if you have some news about the new snap version.

Regards,

--
Jean-Philippe

Jips71
已回答 5 年前
0

Hello

As mentioned in my previous post, I send a ping after a few weeks to see if you have news on this topic.

2 months have passed on this thread without any significant information or evolution of the situation. It is unusual to remain without any sign of AWS on this kind of problem. Could you give us some information on the latest development of the AWS Greengrass Snap and its compatibility with NodeJS, or at least give us something to chew while we wait: for example the underlying reason, technical or otherwise, why it is taking so long to patch a closed source piece of software with patches already open sourced elsewhere - namely NodeJS 8 or 10 and the latest version of AWS Greengrass 1.9.x.

Like me, other users like dahlborg are concerned by this problem. See https://forums.aws.amazon.com/thread.jspa?messageID=907419&tstart=0#907419.

Best regards,

Jean Philippe

Jips71
已回答 5 年前
0

Hi Jips71,

There's an announcement about Greengrass and Snap support.
https://forums.aws.amazon.com/ann.jspa?annID=6967

I'll continue to post updates as they become available.

Thanks,
KR-AWS

AWS
KR-AWS
已回答 5 年前
0

Thanks KR !

--
Jean-Philippe

Jips71
已回答 5 年前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则