AWS Greengrass - 公共组件版本出错

0

【以下的问题经过翻译处理】 你好, 我目前有一台运行AWS Greengrass Core Device的Ubuntu设备,并安装了不同的组件。当尝试更新公共组件aws.greengrass.clientdevices.mqtt.Bridge和其他组件的版本时,部署失败了。查看日志文件greengrass.log,我发现了以下错误:

无法与云计算协商版本,且没有本地版本可提供备用。{componentName=aws.greengrass.Nucleus, versionRequirement={aws.greengrass.LogManager=>=2.1.0 <2.8.0, aws.greengrass.Cli=>=2.5.0 <2.8.0, aws.greengrass.StreamManager=>=2.0.0 <2.6.0, aws.greengrass.clientdevices.IPDetector=>=2.2.0 <2.9.0, aws.greengrass.clientdevices.Auth=>=2.6.0 <2.9.0}}

令人惊讶的是,它要求不存在的版本,比如组件aws.greengrass.clientdevices.IPDetector(最新版本为2.1.4)或aws.greengrass.clientdevices.Auth(最新版本为2.2.3)。

非常感谢您的帮助。 祝一切顺利。

阿尔贝托

profile picture
专家
已提问 3 个月前13 查看次数
1 回答
0

【以下的回答经过翻译处理】 你好Alberto, 此消息的含义是,你的部署无法找到与正在部署的组件的需求相兼容的Nucleus组件的版本。特别是,问题来自于Auth需要版本>=2.6.0,而StreamManager需要版本<2.6.0。 为修复该问题,请检查你的部署,在配置步骤中确保选择每个组件的最新版本。 你也可以通过在部署中包含Nucleus组件并在部署中指定版本来强制特定版本的Nucleus组件。 祝好, Massimiliano

profile picture
专家
已回答 3 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则