由于依赖关系,无法更新核心。

0

【以下的问题经过翻译处理】 我们的设备组仍在运行核心组件版本2.7.0。当我们尝试升级时,似乎与greengrass.cli组件发生冲突,导致部署失败并显示以下错误信息:

“NoAvailableComponentVersionException:没有满足要求的本地或云端组件版本。[...]aws.greengrass.Cli要求>=2.5.0<2.8.0,thinggroup/staging要求=2.9.5。”

然而,该设备上唯一的部署并没有安装greengrass.Cli组件(它在一段时间前已被删除)。如果我尝试添加新版本的CLI组件到部署中,它也会因为依赖项错误而失败:

“[...]aws.greengrass.Cli版本约束:thing/mything01要求=2.7.0”

当我进入设备的菜单时,我可以看到组件“aws.greengrass.Cli v2.7.0”被列为“根”依赖类型(提示语为“这个组件被指定在一个针对这个核心设备的部署中”),但我无法看到这个依赖关系来自哪里,也无法将其移除。

如果我无法从这些设备的部署中看到这种依赖关系,那它可能是从哪里来的,我该如何移除它呢?

编辑:greegrass是使用“--deploy-dev-tools true”安装在设备上的,这可能与问题有关。

profile picture
专家
已提问 3 个月前62 查看次数
1 回答
0

【以下的回答经过翻译处理】 你好,

你发布的第二个错误提示告诉你问题所在。你已经将CLI版本2.7.0部署到了mything01,你必须从该设备的部署中删除CLI,然后才能将更新发布到设备组。问题在于你同时在针对同一设备进行thing和thinggroup 部署,导致冲突。

祝好,

Michael

profile picture
专家
已回答 3 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则