pg_repack扩展升级失败

0

【以下的问题经过翻译处理】 我已将我的Postgresql RDS从12.7升级到13.5,并且我能够升级可用的扩展,如pg_stat_statementsltree等,但除了pg_repack之外。

默认版本:1.4.6

安装版本:1.4.5

当我尝试使用SQL语句升级pg_repack扩展时:

ALTER EXTENSION "pg_repack" UPDATE TO '1.4.6';

错误信息

[22023] ERROR: extension "pg_repack" has no update path from version "1.4.5" to version "1.4.6"

我不确定如何解决这个RDS的问题。

profile picture
专家
已提问 9 个月前35 查看次数
1 回答
0

【以下的回答经过翻译处理】 看起来“pg_repack”没有更新路径。 如果你正在从以前的版本升级“pg_repack”或“pg_reorg”,只需从数据库中删除旧版本并安装新版本即可,具体请参考(https://reorg.github.io/pg_repack/)。

我将发送 PR,更新 AWS 升级文档中的这一说明。

profile picture
专家
已回答 9 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则