如何解决 AL2023 上的 amazon-linux-extras 问题?

0

【以下的问题经过翻译处理】 你好, 我正在进行一个项目,我们使用amazon-linux-extras,但是在升级到AL2023后,我们遇到了一个找不到的错误。我在一些论坛上看到它已被停止使用,你能告诉我是否有任何替代该包的解决方案吗?或者任何其他解决方案,以便我可以下载amazon-linux-extras?

profile picture
专家
已提问 4 个月前26 查看次数
1 回答
0

【以下的回答经过翻译处理】 你好,根据Al2023的FAQ,AL2023不像AL2一样有Amazon-Linux-Extras。对于高级软件包像语言运行环境,我们将使用季度发布,在默认仓库提供的软件包以外,将会添加主要/次要软件包的更新作为单独的命名空间软件包。例如, Amazon Linux 2023的默认Python版本可能是3.8,但是每当Python 3.9 (python39)可用时,我们将添加它作为单独的命名空间软件包。这些附加软件包将严格遵循其上游发布节奏和支持模型,它们的支持政策可通过包管理器用于符合合规和安全性用例。默认软件包将在AL2023的整个生命周期内得到支持。

关于Al2023发布的所有可用软件包的详细信息,可以在这里找到。

如果你需要的软件包在默认仓库中不存在,那么可以通过这个github链接提出请求。

希望这有所帮助。

profile picture
专家
已回答 4 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则