安装Vivado v2018.3_AR73068_op的HDK(FPGA Dev AMI 1.6.1)

0

【以下的问题经过翻译处理】 我已经启动了一个f1 x2large FPGA Developer AMI - 1.6.1-40257ab5-6688-4c95-97d1-e251a40fd1fc-ami-01d5f32a3d517960b.4实例(在Community AMIs中),并且根据 https://github.com/aws/aws-fpga, Developer Kit版本1.4.8-1.4.15a应与FPGA Developer AMI版本v1.6.0-v1.6.X(Xilinx Vivado/SDx 2018.3)兼容。

按照 https://github.com/aws/aws-fpga/tree/master/hdk 上的“安装HDK并设置环境”部分的说明,在克隆到实例并执行source hdk_setup.sh后,我得到以下错误:

** 错误:该HDK版本不支持Vivado v2018.3_AR73068_op(64位)**

错误:支持的版本为: Vivado v2017.4(64位) 。 。 (完整的日志给出在最后) 。 Vivado v2019.2_AR73068(64位)

第一次,我更新了实例的内核,然后尝试安装HDK。我得到了类似的错误(支持的版本更长)。

下一次,我没有更新内核,但我收到了相同的错误。此外,我尝试了其他版本(1.4.8和1.4.15),但仍然收到了相同的错误。

在aws-fpga目录中执行“source hdk_setup.sh”后,以下是完整日志:

INFO:设置环境变量
INFO:基本vivado版本是Vivado v2018.3.op(64位)。检查是否需要安装路径AR71715
INFO:使用Xilinx补丁AR73068修补Vivado 2018.3
INFO
profile picture
专家
已提问 3 个月前4 查看次数
1 回答
0

【以下的回答经过翻译处理】 看起来在版本1.4.15a中,supported_vivado_versions.txt字符串未被更新以包括Vivado v2018.3_AR73068_op(64位)。

我会修复它并发布一个新的1.4.15b标签。

在此期间,你可以通过将Vivado v2018.3_AR73068_op(64位)添加到dev kit clone中的supported_vivado_versions.txt文件中,在Dev AMI 1.6.1上运行hdk_setup。

我们发布修复版本后,我会在这里进行更新。

profile picture
专家
已回答 3 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则