MariaDB 10.2和php7.3不能同时使用吗?

0

【以下的问题经过翻译处理】 无法同时安装php7.3和MariaDB 10.2吗?

当我尝试安装时,会出现以下错误:

amazon-linux-extras install lamp-mariadb10.2-php7.2

拒绝安装,因为lamp-mariadb10.2-php7.2可能导致无效组合。

是否有其他因素导致了这个错误?

profile picture
专家
已提问 4 个月前6 查看次数
1 回答
0

【以下的回答经过翻译处理】 我们创建了lamp-mariadb10.2-php7.2 extra作为一个便捷操作,以便在一个操作中安装大部分LAMP堆栈。在我们创建它的时候,PHP 7.2是最新的版本,所以它是一个显而易见的选择。

我们为extras中的各种PHP版本提供的与MySQL相关的模块未编译为任何特定的客户端库,因此它们应该能够连接到任何类似于MariaDB的MySQL进程。我们提供的所有PHP版本都共享这一点,因此在技术上,您可以使用PHP 7.3与我们的MariaDB包,除了我们没有在兼容通道中提供它们之外,没有其他技术上的原因。

我们正在评估我们应该如何最好地重新排列我们的extras,以纠正这个限制并提供一个未来可用的解决方案。

profile picture
专家
已回答 4 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则