amazon-linux-extras not working

0

getting this error please help me to solve this

已提问 9 个月前278 查看次数
1 回答
1

Hi,

According to Amazon Linux 2023 FAQs page, and unlike Amazon Linux 2, there is no “Amazon-extra-packages” available for Amazon Linux 2023 (AL2023).

No, AL2023 does not have extras. For higher-level software packages like language runtimes, we will use the quarterly release where we will add major/minor updates to packages as separate namespaced packages in addition to the default package provided in the repository. For example, default Python version in Amazon Linux 2023 may be 3.8, but we will add Python 3.9 (python39) as a separate namespaced package whenever it is made available. These additional packages will closely follow their upstream release cadence and support model and their support policies can be accessed by the package manager for compliance and security use cases. Default packages will continue to be supported throughout the life of AL2023.

A more detailed explanation is available on the Comparing Amazon Linux 2 and Amazon Linux 2023 documentation page.

Extra Packages for Enterprise Linux (EPEL) is a project in the Fedora community with the objective of creating a large array of packages for enterprise-level Linux operating systems. The project has primarily produced RHEL and CentOS packages. Amazon Linux 2 features a high level of compatibility with CentOS 7. As a result, many EPEL7 packages work on Amazon Linux 2. However, AL2023 doesn't support EPEL or EPEL-like repositories.

profile picture
专家
已回答 9 个月前
profile pictureAWS
专家
kentrad
已审核 9 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则

相关内容