跳至內容

Docker container fails to start

0

Someone can help me on this issue:

CannotStartContainerError: ResourceInitializationError: failed to create new container runtime task: failed to create shim task: failed to create init process I/O: 1 error occurred: * failed to start binary process: fork/exec /sbin/shim-logger-wrapper: argument list too long : unknown

the container is pulled from ECR. i'am trying to deploy a service on ECS.

已提問 3 年前檢視次數 2155 次

1 個回答
0

This is related to a command in your Dockerfile or docker build file in your ECR that it is expanding as it's executing.

Try pulling image locally and debug it. Here's documentation about to pull image from ECR into Docker on your local machine: https://docs.aws.amazon.com/AmazonECR/latest/userguide/docker-pull-ecr-image.html

AWS

已回答 3 年前

您尚未登入。 登入 去張貼答案。

一個好的回答可以清楚地回答問題並提供建設性的意見回饋,同時有助於提問者的專業成長。