Help with S3 redirect


I am creating my first website.

I have registered and setup as an S3 bucket and it works fine. I would like to make it so redirects to

I set this up as described in AWS documents and it worked fine for a while - but then at some point stopped working. I just get a message the browser cannot find the server.

Originally I was trying to do this with CloudFront and I thought perhaps some old CloudFront stuff had conflicted. I deleted all the CloudFront entries I had.

I have the second S3 bucket setup as Hosting Type: Redirect Request and the endpoint link works fine if I use it directly.

In Route S3 I added the Type A simple record to hosted zone and it routes to:

It's perplexing because it worked fine for a few days and then stopped working. I have tried deleting and recreating buckets so perhaps I have done something incorrectly in the process.

I don't mind sharing the domain name but I am not sure if that is good forum protocol. Thank you for any advice on how to debug this.

已提問 2 年前檢視次數 826 次
3 個答案

Some more troubleshooting is required here:

First, make sure that the DNS (Route 53) is set up correctly. From a command-line prompt, use nslookup or dig to ensure that the record is available. Even something like ping is fine - you want to make sure that it returns an IP address.

Second, do the same thing with

Then, check the redirect configuration in S3 for

I wouldn't suggest sharing private information in this forum; if you're still having difficulty definitely raise a ticket with the support team as they some visibility into how you've configured the services and can help from there.

profile pictureAWS
已回答 2 年前

Thank you for responding.

I have confirmed that ping fails - while ping is fine.

I am not certain if this means the redirect configuration should still be investigated, or does this mean the problem is definitely happening earlier such as in the Route S3 setup where I have the hosted zone? I appreciate your clarification.

I have inquired with Tech earlier but I am on the free account so they suggested I use the forums. They pointed me to the docs for setting up S3 redirect which did work at first. It worked fine for a few days then stopped working without any changes to my AWS setup. I assumed something I did was pending and updated after a few days to break it.

已回答 2 年前

Thank you. I have resolved this.

You response led me to look back at my Route S3 - realized at some point trying to get CloudFront to work I had added a second hosted zone for The correct solution after reviewing the docs was to have a single hosted zone and add the record for It is now working for me.

已回答 2 年前

您尚未登入。 登入 去張貼答案。