File Gateway on VMWare ESXi 7.0 on Raspberry Pi

0

FYI this is just for educational purposes, I have no intention of running production workloads on a RPi.

Anyways, I was wondering if anyone has come around to deploying the aws storage gateway OVA onto ESXi 7.0 on ARM Fling.

I tried to do it, but even after tweaking the ovf settings for the vm I was still unable to boot it, so I extracted the ova, and created a VM manually, but even then it did not work and ended up with a core dump...

I pastebined the vmware.log for the core dump here: https://pastebin.com/y88AQNjP, and the vmx file here: https://pastebin.com/ckiXPELF

Anyways, just curious if anyone has ever tried and if it would be possible at all...

已提問 3 年前檢視次數 417 次
1 個回答
0

Hello,

I'm Mike with the Storage Gateway team.

The issue you are having is caused by the fact we don't offer an ARM compatible image for the SGW product line. I did some research and there aren't any plans to make ARM an option in the near future.

Even if we had a workable image, the biggest RPi I saw on their product page (RPi 4) has 4 processors and 8GB of RAM. The storage gateway requires 4 CPU and 16GB of RAM ( https://docs.aws.amazon.com/storagegateway/latest/userguide/Requirements.html#requirements-hardware ), so a virtualized Raspberry Pi wouldn't run the gateway to an acceptable level for even testing purposes.

Please let me know if there are any other questions I can help you with.

AWS
已回答 3 年前

您尚未登入。 登入 去張貼答案。

一個好的回答可以清楚地回答問題並提供建設性的意見回饋,同時有助於提問者的專業成長。

回答問題指南