How do you update Amplify build version for CI/CD?

1

The root problem is that I cannot successfully build my app. I get the error: "File project: data should NOT have additional properties: 'graphqltransformer'"

This led me to the following thread: https://github.com/aws-amplify/amplify-cli/issues/6117. It appears that I need to set my amplify build version to a later version. However, I don't think the advanced settings are accessible anymore in the latest version of the aws amplify console.

In the amplify console, in the provision tab I can see "ENV VERSION_AMPLIFY=6.3.1" My local cli is amplify 7.6.5

What is the easiest way to either remedy the error or update the amplify version that docker is using in the build process?

Bonus question: local amplify cli update fails from 7.6.5 to 7.6.7 when running 'npm i -g @aws-amplify/cli'

adam
已提問 2 年前檢視次數 1925 次
2 個答案
0

I was experiencing the same problem and just figured it out myself. Sign in to AWS and go to the Amplify page. Under "App settings" on the left-side navigation pane, go to "Build settings". Scroll down to the "Build image settings" section and click the Edit button. A window will pop up, under the "Live package updates" section click on the "Add package version override" dropdown and select Amplify CLI. You can try matching it to your current CLI version or leave it set to "latest", and click Save. Now you can go to your Amplify project, click on any icon in the pipeline chart (Provision - Build - Deploy - Verify) and in the top right of the page click on the "Redeploy this version" button.

Steps for configuring live package updates can also be found here.

andrew
已回答 2 年前
0

You may also try the following command that worked for me :

sudo npm install -g @aws-amplify/cli --unsafe-perm=true
AWS
已回答 10 個月前

您尚未登入。 登入 去張貼答案。

一個好的回答可以清楚地回答問題並提供建設性的意見回饋,同時有助於提問者的專業成長。

回答問題指南