Losing internet access with split tunnel on in aws client VPN

0

I have client VPN set up with split tunnel enabled and have just one route i.e. to target subnet in a VPC. I have gone throug other similar question on AWS re:Post and have made sure that I do not have 0.0.0.0 route in Routes associated with Cvpn endpoint. Also I am not supplying and DNS servers at the moment.

vpn-config local-route-table cvpn-route-table

I can see why I am loosing the internet access which is because a route entry is being pushed down to my local route table (i am using Linux Mint 21 and default openvpn client inbuilt into it to connect) for 0.0.0.0 -> 10.54.0.161 which does not make sense. That route entry should not be pushed by Cvpn to my host machine as I have split tunnel enabled.

Not sure what am I doing wrong.

已提問 1 年前檢視次數 570 次
1 個回答
1
已接受的答案

Hope this helps others having issues with CVPN on debian clients.

I had got in touch with AWS Business support about this and they have suggested a workaround in form of using the AWS Client VPN GUI that is available for Linux. When connecting through that software, the default route does not get added but if you use the default open vpn client that gets shipped with linux mint that the issue pops up again.

This should not be happening but they aren't sure about when AWS will prioritize fixing this. So the current solution is using the AWS CVPN GUI. Also the GUI is not supported for newer ubuntu versions but you will need to manually add a few dependencies and then it does work.

Thanks

已回答 1 年前
profile picture
專家
已審閱 1 個月前

您尚未登入。 登入 去張貼答案。

一個好的回答可以清楚地回答問題並提供建設性的意見回饋,同時有助於提問者的專業成長。

回答問題指南