EC2 instance is not reachable by public IP

0

Hey guys,

I understand there is a million questions like this every day. However mine is different. I did not change a thing in my account. All VPC resources were created by Amazon. I tried all troubleshooting tutorials I could find to no avail. I tried launching instances in 3 different regions - same result. Again I did not create/configure any of the VPC stuff, the instance is launched into a default VPC, default subnet and SG is default too.

Thanks,
Denis

已提問 4 年前檢視次數 9476 次
2 個答案
0
已接受的答案

Hi Denis,

It is expected that you would not be able to reach instance over its public IP with default settings.

default security group associated to the instance, allow inbound traffic from network interfaces (and their associated instances) that are assigned to the same security group.

[+]: https://docs.aws.amazon.com/vpc/latest/userguide/VPC_SecurityGroups.html#DefaultSecurityGroup

Therefore, to access instance over its public IP from your source machine, please add inbound rules to the security group.

To access windows instances:
[+]: https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/authorizing-access-to-an-instance.html#add-rule-authorize-access

To access linux instances:
[+]: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/authorizing-access-to-an-instance.html#add-rule-authorize-access

I hope this helps.

已回答 4 年前
profile picture
專家
已審閱 1 年前
0

Oh, man. It's so simple it's embarrassing. Thank you very much!

已回答 4 年前

您尚未登入。 登入 去張貼答案。

一個好的回答可以清楚地回答問題並提供建設性的意見回饋,同時有助於提問者的專業成長。

回答問題指南

相關內容