AWS Device Farm Appium 1.22.0 iOS 15 support for Appium python test?

0

Unable to start Appium server when selecting Appium 1.22.0 in testspec.yml for Appium python tests error : appium server never started in 60 seconds. Exiting

已提問 2 年前檢視次數 620 次
1 個回答
0
已接受的答案

Did you update the version of node first? Try adding this to your test spec file before changing the appium version

      - export NVM_DIR=$HOME/.nvm
      - . $NVM_DIR/nvm.sh
      - nvm install --lts
已回答 2 年前
profile picture
專家
已審閱 2 個月前
  • Thanks it solved the Appium server not starting issue but now iam getting Error code 65 No application is open error on iOS 15 devices(iOS 14 works fine), iam trying solutions but let me know if you have any solutions for it, Thank you

  • Please share the part of your code where you start appium driver. Are you ensuring not to set desired capabilities when you run in device farm?

  • here is code where i start appium driver, Note : with this settings iOS 14 works as expected but iOS 15 does not yml file : version: 0.1 install: commands:- cd $DEVICEFARM_TEST_PACKAGE_PATH - . bin/activate - export NVM_DIR=$HOME/.nvm - . $NVM_DIR/nvm.sh - nvm ls-remote - nvm install --lts - pip install --upgrade pip - pip install -r requirements.txt - export APPIUM_VERSION=1.22.2 - avm $APPIUM_VERSION - ln -s /usr/local/avm/versions/$APPIUM_VERSION/node_modules/.bin/appium /usr/local/avm/versions/$APPIUM_VERSION/node_modules/appium/bin/appium.js

    for desired capabilities I only set Remote url

  • That's the .yml file There should be a place in your test where you start the driver. self.driver = webdriver.Remote(url, desired_caps) Please ensure that desired_caps is empty and that you aren't setting the platform version there

  • Yes, iam using Robotframework Open Application http://0.0.0.0:4723/wd/hub

    iOS 14 works as expected but iOS 15 does not

您尚未登入。 登入 去張貼答案。

一個好的回答可以清楚地回答問題並提供建設性的意見回饋,同時有助於提問者的專業成長。

回答問題指南